Upgrading my PC’s PSU

My old PSU sitting on my desk, post-operation.

My old PSU sitting on my desk, post-operation, alongside Reuben’s toolkit.

Early on Sunday morning I switch on my PC and nothing happened. Nothing. Not a sound. Not a spark. Nothing. All a bit worrying really given that I wanted to get some prayers off my hard drive for use in the 08:00 service that morning.

Troubleshooting

I tried not to panic and think about it logically. What could the problem be? Okay, the power comes into the power supply unit which then feeds the motherboard and the various components (DVD, hard drives, graphics card, soundcard, USB devices, etc.) But the PSU is in standby mode until it’s supplied with a load which only happens when I push the on/off switch. There are my first two candidates: PSU and switch. And it it’s not them then I guess it could be the motherboard?

I took a look at the switch. It looked and sounded fairly solid. I then hunted down another power cable and swapped that out. Maybe the fuse had gone, I reasoned. And remarkably, my PC started (after two or three failed attempts). That immediately ruled out a dodgy motherboard.

It was looking more and more likely that the PSU was the source of the problem.

Review

So I searched online for the make and model of my then-current PSU: EZCOOL ATX-600JSP and was astonished to read a review on Amazon UK which described something very close to the problems that I had been experiencing for the last couple of years.

For the last couple of years I’ve had a intermittent issues whereby I’d switch on the PC and it would start only to switch itself off a few seconds into the boot sequence. I’d put it down to my not pressing the button hard enough, or even thinking that perhaps there was a problem with the button itself.

Here is what Bukkithead said on Amazon:

For the love of all things holy, don’t buy this power supply. Hamsters on running wheels are a more reliable source of power than this.

Fortunately, I didn’t buy this. I borrowed it from a friend as my old PSU was only 450W and couldn’t handle my new NVIDIA 8800 GTX graphics card.
For about a month, everything was fine. Admittedly sometimes the computer wouldn’t turn on, but it did after pressing the button again and I attributed that to the case rather than the PSU.
However, after this time of false happiness, I was using my computer one day and the power just died. I was surprised but assumed it was a power surge or something similar. Then after a while it would cut out as the computer was turning on or within the first few minutes of running. It was fairly annoying having to have two or three attempts to turn my computer on, and this happened more often than not.
After getting used to this for another couple of weeks, the thing really started to die, a few days ago it turned itself off twenty times, accompanied by a worrying fizzing sound. I tried switching power cables but this made no difference whatsoever. Now it’s more useful as a doorstop and I look forward to destroying the damn thing.
In the last few days I have bought and installed a new Corsair HX series PSU, which never turns off, drastically improved the performance of my computer and is actually silent, unlike this one which claims to be but is far from it. An added bonus is that the inside of my computer no longer looks like a jungle thanks to the modular cabling. The Corsair is highly recommended and is well worth the money, albeit a fairly large sum.
Cheap things are cheap for a reason. Please save yourself the trouble.

New PSU

I ordered a new PSU, the Corsair GS800 80 Plus Bronze Certified Power Supply 2013 Edition which arrived this afternoon.

Reuben helped me to fit it; what a sweetie! You can see from the photo above that he brought his own toolkit to my desk to help.

The operation was pretty straightforward:

  1. Unplug everything from the back (and front) of my PC.
  2. Remove the two side covers.
  3. With anti-static wristband on, carefully remove the existing power connectors: the motherboard had two (24-pin and 4-pin), graphics card (6-pin), soundcard breakout box and floppy drive (small 4-pin), DVD drives (molex 4-pin), SATA hard drives (SATA connectors).
  4. Unscrew and remove the old PSU.
  5. Fit new PSU.
  6. Carefully attach the new cables.
  7. The Corsair website was useful in discovering that I had to split the new 8-pin connector marked “CPU” so that it could fit the 4-pin ATX 12V socket on the motherboard.
  8. Screw the PC sides back on.
  9. Connect the cables again,
  10. Switch on… and pray that it works.

It did! My PC is now disconcertingly quiet. It starts up with a whirring flurry of noise before almost immediately dropping down to an almost inaudible whisper. So quiet was it the first couple of times that I thought my PC had switched itself off. I breathed a sigh of relief when I saw the screen flicker into life and I watched the power-on startup test (POST) begin.

Next…

Having recently upgraded my RAM too—doubling it from 4GB to 8GB—which involved some first class customer service from Crucial, my PC is slowly getting a new lease of life. Not had for a machine that I bought about five or six years ago:

  • Asus P5N-E SLI motherboard
  • Intel Core 2 Quad Q6600 CPU
  • Crucial 8GB DDR2-667 RAM
  • NVIDIA GeForce 8800 GT 512MB graphics card

Next up, I want to upgrade the graphics card from an NVIDIA GeForce 8800 GT (still a remarkably capable graphics card) to something more powerful. I’ll be sure to report back.

Winamp Global Hotkeys and Microsoft Digital Media Pro keyboard

I’ve just spent, on and off, about 2 hours trying to work out why the media keys on my Microsoft Digital Media Pro keyboard weren’t working properly with Winamp 5.541 Pro.  I’ve finally managed to solve the problem by rolling back to older keyboard drivers.

It appears that the Intellitype 6.3 drivers aren’t compatible with Winamp 5.541 Pro.

Intellitype 6.3

When I reinstalled Windows XP Professional a couple of weeks ago I did as I was supposed to: I installed the latest keyboard drivers (Intellitype Pro 6.3). But when it came to setting up Winamp I discovered that it didn’t work as expected.

Winamp has a Global Hotkeys setting within its preferences. As the explanatory text says:

Global Hotkeys are keyboard shortcuts that you can use from within any running application.

And here you can “enable default multimedia key support”. My keyboard (the Microsoft Digital Media Pro) has multimedia keys, so what could be more simple?

Global Hotkeys enabled

I ticked the option, both options in fact, and closed the preferences dialog box.

Pressing the Play/Pause button once started the MP3 track.  Pressing it again paused it.  Success!

But then I minimized Winamp, pressed Play/Pause again and Windows Media Player started.  Eh?!

Troubleshooting

I tried a variety of solutions on the Winamp forums. Tick one, close, stop itype.exe, restart Winamp, reselect the option, close Winamp, start itype.exe … all that jazz.  Nothing worked properly.

How frustrating!

Rollback to Intellitype 6.1

I know that it worked with the last Windows installation, and I knew that I’d used the Intellitype 6.1 drivers, so I uninstalled Intellitype 6.3, rebooted my PC and reinstalled version 6.1.

And do you know what?  It worked.

What I’ve had to do in the Intellitype options is disable the Play/Pause button (because enabled it was still opening Windows Media Player) but it didn’t have any effect on Winamp’s ability to recognise or use the key.

Now when I press Play/Pause, no matter whether Winamp is minimized or maximized it toggles play and pause.

What’s missing

Intellitype 6.3 appears to offer a few new features not present in 6.1, such as the ability to save keyboard profiles, but to be honest I don’t need such a facility.  So long as my keyboard shortcuts work and my multimedia keys control Winamp I’m a happy user.

My Seesmic debut

Today I made my internet debut on Seesmic: the video conversation website.

I remember someone leaving a comment ages ago when they heard my voice on an MP3 file saying that it kind of freaked them out to hear me because up until then I’d just been an anonymous stranger behind the written word. Well, now you get pictures too! I hope it’s not too upsetting for you.

I was quite unsure about whether I’d enjoy it or not. What would I have to say? Would I want to join in any conversations? But to be honest it was great. It was easy and people were really friendly.

The embedded video above was my Seesmic debut. I introduced myself and a bit like wandering into a room of strangers before long someone said hi and we got chatting. Except that both of us were sitting at home looking into a webcam.

Seesmic simplicity

The Seesmic software is tremendously easy to use. Once you’ve logged in all you have to do the first time is make sure that the camera, microphone and speaker settings are assigned to the devices you want them to be set to and then you simply click on record and get chatting. It couldn’t be simpler.

Recording directly to the website makes it so much easier to use than say YouTube where you need to record to a particular video format, upload that file to the website, which then takes time to convert to Flash format, and eventually view a couple of hours later. Seesmic is almost instant; it’s great.

The only issue is that after watching Seesmic videos it seems to mess up my audio playback settings and my MP3s then sound like they’re being played by a chipmunk band!

Nothing that a quick mode change on my soundcard doesn’t fix, but I’d like to prevent that if possible. It’ll be to do with a change in bitrate or something, but it sure is annoying.

What’s the point?

It’s like video blogging, I think — you can start new threads or leave comments. But unlike a blog where you type you just chat. It’s far more personal, you can really show your personality, your gestures are obvious and, of course, you can wear odd hats too!

Epson Perfection V200

Epson Perfection V200 scanner

On Wednesday evening I sat down at my PC and tried to scan a document on my Epson Perfection 1670 Photo scanner.

Troubleshooting

I placed the document on the scanner’s glass, closed the lid and fired up the scanning software (Epson Scan).

Scanning …

Nothing.

I tried again. Again nothing. Every time I tried the scanner appeared to work okay but presented me with the same thing: an A4 sized blank document.

Switching it off and switching it back on again (that favourite of technical support) didn’t fix it. Reinstalling the software didn’t fix it.

Searching Google confirmed what I feared: a hardware error.

I suspect that since you can’t switch off the scanner, short of pulling out the power cable, it eventually burned itself out. Maybe it got zapped during a recent power cut and surge.

I don’t know. All I knew is that my scanner no longer worked.

New scanner

My new scanner arrived on Friday morning, the Epson Perfection V200 Photo.

This one works, it scans faster, but even better: it has an on/off button. It’s important to switch off your peripherals when you’re not using them.

Initial impressions: Cube Scorpius ST10

Black and silver PC with 2 monitors and 5 speakers

Last night I had a proper chance to check out my new PC, a modified Cube247 Scorpius ST10. Here’s a quick review.

If you can’t be bothered to read it all just scroll down to the conclusion.

Packaging (4/5)

The system came neatly packaged in five boxes:

  1. PC case, Windows and drivers CDs and component manuals
  2. Monitor
  3. Monitor
  4. Creative 5.1 speakers
  5. Keyboard, cables, etc.

Everything looked well-packaged and protected, which is what you want.

What I received (4/5)

I promptly checked that everything was in order — to see if I’d received what I’d ordered. All was well until I got to the monitors. There was one VGA-to-DVI adapter missing. They look like this:

VGA to DVI adapter

I telephoned Cube yesterday (Friday) who dropped one into the post; it arrived this morning (Saturday).

Case (3/5)

The case — a Foxconn TLA-570A — looks solid, well built and good quality. It’s just as it looks in the photo (above): black and silver, with four 5.25″ slots (two already filled with DVD drives), one 3.5″ slot for the floppy drive, 2 x USB and audio in/out ports.

It’s nothing special, certainly not the first choice of Custom PC magazine, I would guess! Not as sexy as the Antec Nine Hundred or A+ CS-188AF. But I imagine that it will sit quite happily under my desk keeping my PC components in the right place.

Opening the case up everything looks quite neat, allowing good airflow around shiny bits of metal that start to get really hot when you allow electricity to go racing through its components. One thing that I like is a funnel attached to the inside of the removable case-side that when closed ducts the air from the graphics card directly out of the case.

One disappointment is that while the website states that the PC comes with 12 USB ports there are only 10. (UPDATE: Actually, there were 12 but two of them were inside the machine.)

Monitors (4/5)

The two monitors are 19″ TFT models by Hannstar I-INC CY199. The monitor fits neatly into the base, clicking into place to keep it secure.

Besides a standard “kettle flex” power connector there are two data input ports: a D-Sub VGA connector and a DVI-Digital (Single Link) connector.

According to the “standard timing table” in the manual the monitor has a maximum resolution of 1280 x 1024 @ 75 Hz.

The first monitor I tried had one “stuck pixel”, but this was easily fixed by gently tapping the screen or rubbing it with a cloth.

Keyboard and Mouse (4/5)

The keyboard and mouse are good, solid Logitech input devices. They are standard devices with no extra multimedia buttons, but they feel really good to use.

However, I’ll be using my Microsoft Digital Media Pro keyboard and Microsoft Intellimouse Optical mouse.

Speakers (5/5)

The speakers are the Creative Inspire T6100 surround-sound speakers in a 5.1 configuration, that is five satellite speakers and one sub-woofer to handle bass.

Specs are:

  • 8 watts RMS per channel (4 channels)
  • 18 watts RMS centre channel
  • 26 watts RMS subwoofer
  • Frequency Response 40Hz – 20kHz

The satellite speakers plug into the sub-woofer, which connects to both the power cable and the soundcard. An on/off and volume control is built into the right hand front speaker.

So far I’ve only tried out the sub-woofer and front left, centre and right speakers, and they sound great, especially with the Creative X-Fi soundcard.

Drivers and component documentation (5/5)

Something that has impressed me about Cube is that, unlike some of their competitors, they send you the original discs, not just recovery discs. They sent me:

CDs

  • Windows XP Professional SP2 OEM
  • Asus P5N-E SLI motherboard support CD
  • Asus software bundle CD
    • Norton Internet Security 2007
    • Corel Snapfire Plus SE 1.2
    • Intervideo DVD Copy 5 Trial
    • Acrobat Reader
    • DirectX 9.0c
    • Multi-language Installation Guide
  • Asus GeForce 8800GT drivers CD
  • Asus GeForce 8800GT manual CD
  • Creative X-Fi drivers CD (Windows XP)
  • Creative X-Fi drivers CD (Windows Vista)

Manuals

  • Windows XP Professional
  • Asus P5N-E SLI motherboard user guide
  • Asus P5N-E SLI motherboard quick start guide
  • Intel Core 2 Quad processor installation instructions
  • Asus Graphics Card SpeedSetup guide
  • LCD monitor users manuals and warranty cards
  • Creative Inspire T6100 quick start guide and warranty card

The only thing that appears to be missing is any documentation to do with the Creative X-Fi sound card. When I purchased a retail X-Fi card a few years back it certainly came with a quick start guide. Perhaps the OEM version doesn’t and it’s all on CD now.

Retailer documentation (0/5)

There was no documentation from Cube. No invoice, no instructions, nothing.

A telephone call on Friday morning revealed that the invoice would be posted to me separately. Which is fair enough, but a short note at least saying “hello, thanks for buying from Cube if you’ve got any problems then call us and we’ll do our best to answer your query” would have been courteous.

It’s just as well that I know my way around a PC. If this had been my first system then I may have been completely lost trying to work out what connected to what.

Motherboard (4/5)

The motherboard used is the Asus P5N-E SLI, built around the NVIDIA® nForce® 650i SLI Northbridge and NVIDIA® nForce® 430i chipsets.

The Scorpius ST10 uses the Intel Core 2 Quad 6600 processor. It’s fast. Custom PC magazine said of it “the Q6600 is one of the best CPUs ever made.”

The motherboard supports the usual host of exciting kit, including

  • 2 x PCI Express x 16 slots
  • 1 x PCI Express x1
  • 2 x PCI 2.2
  • 4 x Serial ATA drives; 1 x External SATA (all 3Gb/s)
  • 4 x IDE drives

All this new technology is great and all, but I still need a good old fashioned serial (COM) port for connecting my Psion.

While there isn’t a serial port on the rear panel there is actually a serial port built into the motherboard (verified by the BIOS, although not mentioned at all in the manual!) … assuming that you can find the correct motherboard header for it; it uses the IDC 10-pin connector. (Lose 1 point — a break-out backplate would have been a welcome addition, as well as information in the manual about it.)

Lindy sell the PC backplate serial adapter for around £6.00; also available Amazon UK.

BIOS (0/5)

The Asus P5N-E SLI motherboard uses the Phoenix AwardBIOS.

Apparently.

I couldn’t get access to it: it was password protected. And if you remember, I didn’t get any documentation from Cube, I don’t have the password. (Lose 5 points!)

I tried a few defaults: password, enter, sesame, cube, cube247, etc. Nothing I tried worked.

Computer Shopper magazine discovered the same thing:

To prevent potentially dangerous tampering, the BIOS is password-protected, although the password can be obtained from Cube’s technical support. (Computer Shopper review of Cube 247 Zeta ST4)

I phoned Cube this morning, but was told that I could only get the password from their Tech Support guys who work Monday – Friday. But why did I want the BIOS password? he asked me. The BIOS has been setup, he said, I didn’t need to change anything. It would violate the warranty, he told me. Which is interesting, because I didn’t actually get any paperwork about the warranty.

“But this is MY PC now,” I said. “So I want the BIOS password.” After all, the customer is always right.

UPDATE: As I recall the password was: letmein.

Switching on (3/5)

When I first switched on the PC I had to go through the initial Windows XP registration steps: XP licence key, PC name and network ID, user names, etc. But then as soon as I was into Windows XP I was presented with a couple of drivers still needing installed: network card and (I think) RAID or SATA drivers. Popping the Asus motherboard support CD into the DVD drive seemed to appease its driver-hungry craving and all was well.

I rebooted, and to my surprise had to go through part of the process again. Very odd. (Lose 1 point!)

Then I realised that the Creative X-Fi applications weren’t installed, although the basic drivers appeared to be. That took a few minutes (I’ve done it loads of times on my current machine) but it’s not the sort of thing that an inexperienced computer user might know to do. I suspect that a lot of users would expect it all to be installed and ready to go. (Lose another point!)

That said, one thing that did impress me is that there is absolutely no extraneous software installed. Each time I restore my Lenovo laptop to factory defaults I then have to spend the next 30 minutes uninstalling all the sponsored crap that’s also installed by default.

This is a very clean system when new, which is refreshing and to be commended.

Conclusion (4/5)

All in all, I’m really impressed with this machine. While there were a few niggles (mystery BIOS password, sticky pixel, not all drivers installed out-of-the-box) they weren’t enough to make me think less of this PC or Cube.

I’m now really looking forward to unlocking the BIOS, removing the RAID 0 (stripe) configuration, repartitioning the drives as two independent/standard 500 GB drives, reinstalling Windows XP (on three partitions: general, games-only, video-edit-only) and migrating my data over.

This new PC is way faster and more capable than my current machine — I can now run Battlefield 2 with everything turned up to HIGH, Creative X-Fi sound effects on, Anti-Aliasing at 8x, and a resolution of 1280 x 960 @ 60 Hz and it hardly breaks a sweat!

This should allow me to do some serious gaming, video editing and Web development for some time to come.

As for Cube247 I would certainly recommend them. Their build quality seems to be very good, their customer service has been excellent the few times that I’ve had to call them, and their prices were excellent — there’s no way I could have got this spec of machine by building it myself. But that’s what I tend to do anyway: buy something that is as close to what I want as possible and then tweak it the rest of the way.

Update – Monday 28 January

Customer Service (5/5)

I phoned Cube this morning to ask for the BIOS password. They were (understandably) a little hesitant to give it to me but when I explained that I wanted to add a couple more hard drives to it (for data migration purposes) they gave me the password, which should now let me in.

On of the first things I always do when I get a new system is take a record of the default BIOS settings. Just in case.

My new PC arrived, however …

Cube247 Scorpius ST10 PC

This afternoon my new PC arrived. The company had said that it would be here before 4:00 pm, and sure enough at 3:56 pm the delivery van pulled up outside and delivered five boxes of shiny new technology.

This evening I unpacked the boxes only to discover that I can’t connect both monitors. Here are the connectors that I have:

Monitor input

  1. VGA (D-Sub)
  2. DVI-D Single Link

Graphics card output (Asus GeForce 8800GT)

  1. DVD-I Dual Link
  2. DVD-I Dual Link
  3. HDTV-out

Cables

  1. VGA (D-Sub) to VGA (D-Sub)
  2. VGA (D-Sub) to VGA (D-Sub)

Converter

  1. VGA (D-Sub) to DVI-I (Bundled with Asus graphics card)

In other words I only have two VGA-to-VGA cables but no VGA outputs on the PC to plug them into. At most I can connect one monitor using the converter but then it won’t be a digital-to-digital connection, which I’m sure will be a faster, sexier connection.

I’ll get on the phone tomorrow to Cube 247 and try to resolve this. A simple oversight, I’m sure. You’d think that if they were selling a dual-monitor system then you’d be able to connect both monitors straight out of the box. Especially if you’re paying over a grand for it.

Update

Friday 25 January 2008

I had a look in graphics card manual after I’d posted this last night and discovered that it reckoned that the graphics card had

  1. VGA (D-Sub)
  2. DVD-I Dual Link
  3. HDTV-out

as well as the VGA-to-DVI converter. That offers one explain why I’m one connector down: the graphics card hardware has been changed but perhaps the PC manufacturer hadn’t fully realised this.

Update #2

I called Cube247 — it was a simple omission, and a second VGA-to-DVI converter will be posted out to me today. That is after all what I’ve paid for.

I’ve also ordered myself two new Belkin Pro DVI-D to DVI-D cables so that I get a better image. (I think that’s how it works!)

Update #3

The second VGA-to-DVI converter arrived the following morning, on Saturday. Great service from Cube247.

I’ve just ordered a new PC

Cube 247 Scorpius ST10

I still can’t quite believe it: I’ve just ordered myself a new PC from Cube247.

My current PC has been slowly dying over the last few months. Even after a complete reinstall it falls over during the most mundane of tasks: watching video online, ripping CDs to MP3, erm … checking the time.

It did it again this morning. I complained (again!). Lovely Jane turned to me and said “Just order a new one!” So I did.

Having been pricing it for the last couple of months, and doing a bit of digging around for the right spec, I decided in the end that convenience would take precedence over adventure and I’d just order a complete system rather than build and tweak it myself.

I’d been impressed with the reviews that Cube247 were getting and it turned out to be cheaper too (to buy rather than build) for the kind of spec that I wanted.

I wanted at least an Intel Core 2 Duo E6750, and the recent CPU group review in Custom PC magazine this month helped me to choose. The Intel Core 2 Quad Q6600 scored second in the “Bangs per buck” category (E6750 was first), and 13th in the “Overall” category (E6750 was 17th).

Here’s what I’ve ordered, it’s based on the Cube247 Scorpius ST10:

  • Microsoft Windows XP Professional
  • Intel Core 4 Quad Q6600 Processor
  • 4096MB Corsair DDR II 667 Memory
  • 1000GB SATA II Seagate Data Storage – RAID Stripe
  • NEC 7170 Multi Format DVD/CD ReWriter
  • nVidia GeForce 8800 GT 512MB PCI Express Graphics Card
  • Creative Labs XFi Xtreme Gamer Sound Card
  • Asus P5B-E SLI Motherboard
  • 600w Silent PSU
  • Sony Floppy Disk Drive
  • DVD/CD ROM Drive
  • 2 x 19″ TFT 8ms Flat Panel Screens
  • Logitech Multimedia Keyboard
  • Logitech Optical Mouse
  • Creative Inspire 6100 5.1 Speaker System
  • 10/100/1000 Ethernet LAN
  • 12 x USB2 Ports
  • Firewire

That should be just enough bang-for-buck raw power to allow me to write a couple of websites, surf the ‘net and use Microsoft Word. What do you reckon? ;)

I might even be able to get in a full game of Minesweeper quite comfortably on that setup.

Quite a step up from my current AMD Athlon XP 2800+, 1 GB RAM, ATi Radeon X700. But as you can see from the spec above I’m sticking with Windows XP Professional for now.

It’s worth pointing out too that this is the first time in my desktop PC-buying experience that I’m going for an Intel/Nvidia combination of CPU/graphics card rather than AMD/ATi. Just goes to show that Intel and Nvidia are clearly ahead of the game right now.

All being well, it arrives on Thursday.